import Foundation
let pattern = #"\b'\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"$sql = INSERT INTO my_table VALUES ( 123, '456', 'Don't fail', 'hellow world' )"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\'"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)