// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b'\b").unwrap();
let string = "$sql = INSERT INTO my_table VALUES ( 123, '456', 'Don't fail', 'hellow world' )";
let substitution = "\\\\'";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}