#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b'\b"
Local $sString = "$sql = INSERT INTO my_table VALUES ( 123, '456', 'Don't fail', 'hellow world' )"
Local $sSubst = "\\'"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)