#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:"defaultMsg":")([^"]+)".*(?:"userName":")([^"]+)""
Local $sString = "Aug 25 17:31:05 1.1.1.1 consoli: ad ad ad ,"defaultMsg":"Updated VM hostname" asd asd ,"userName":"abc@abc.com", ada"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")