const regex = /(?:"defaultMsg":")([^"]+)".*(?:"userName":")([^"]+)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:"defaultMsg":")([^"]+)".*(?:"userName":")([^"]+)"', 'gm')
const str = `Aug 25 17:31:05 1.1.1.1 consoli: ad ad ad ,"defaultMsg":"Updated VM hostname" asd asd ,"userName":"abc@abc.com", ada`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}