$re = '/(?:"defaultMsg":")([^"]+)".*(?:"userName":")([^"]+)"/m';
$str = 'Aug 25 17:31:05 1.1.1.1 consoli: ad ad ad ,"defaultMsg":"Updated VM hostname" asd asd ,"userName":"abc@abc.com", ada';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);