import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\"defaultMsg\":\")([^\"]+)\".*(?:\"userName\":\")([^\"]+)\"";
final String string = "Aug 25 17:31:05 1.1.1.1 consoli: ad ad ad ,\"defaultMsg\":\"Updated VM hostname\" asd asd ,\"userName\":\"abc@abc.com\", ada";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}