// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:"defaultMsg":")([^"]+)".*(?:"userName":")([^"]+)""#).unwrap();
let string = "Aug 25 17:31:05 1.1.1.1 consoli: ad ad ad ,\"defaultMsg\":\"Updated VM hostname\" asd asd ,\"userName\":\"abc@abc.com\", ada";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}