#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-fA-F0-9]{2}:[a-fA-F0-9]{2}$"
Local $sString = "02:222222" & @CRLF & _
"fail" & @CRLF & _
"00:20" & @CRLF & _
"expected output: pass" & @CRLF & _
"00:202" & @CRLF & _
"expected ouput: fail" & @CRLF & _
"00:2z" & @CRLF & _
"expected output: fail" & @CRLF & _
"000:2" & @CRLF & _
"expected ouput: fail"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")