$re = '/^[a-fA-F0-9]{2}:[a-fA-F0-9]{2}$/m';
$str = '02:222222
fail
00:20
expected output: pass
00:202
expected ouput: fail
00:2z
expected output: fail
000:2
expected ouput: fail';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);