// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-fA-F0-9]{2}:[a-fA-F0-9]{2}$").unwrap();
let string = "02:222222
fail
00:20
expected output: pass
00:202
expected ouput: fail
00:2z
expected output: fail
000:2
expected ouput: fail";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}