use strict;
my $str = '02:222222
fail
00:20
expected output: pass
00:202
expected ouput: fail
00:2z
expected output: fail
000:2
expected ouput: fail';
my $regex = qr/^[a-fA-F0-9]{2}:[a-fA-F0-9]{2}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}