import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-fA-F0-9]{2}:[a-fA-F0-9]{2}$";
final String string = "02:222222\n"
+ "fail\n"
+ "00:20\n"
+ "expected output: pass\n"
+ "00:202\n"
+ "expected ouput: fail\n"
+ "00:2z\n"
+ "expected output: fail\n"
+ "000:2\n"
+ "expected ouput: fail";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}