const regex = new RegExp('^[a-fA-F0-9]{2}:[a-fA-F0-9]{2}$', 'gm')
const str = `02:222222
fail
00:20
expected output: pass
00:202
expected ouput: fail
00:2z
expected output: fail
000:2
expected ouput: fail`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}