re = /^[a-fA-F0-9]{2}:[a-fA-F0-9]{2}$/m
str = '02:222222
fail
00:20
expected output: pass
00:202
expected ouput: fail
00:2z
expected output: fail
000:2
expected ouput: fail'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end