using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Z(?:123|124)(?:xy|od).*?(:?;|$))";
string input = @"Z124xy54;Z123od33;Z251od541;Z123od343;Z251ab541;Z123od343";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}