$re = '/(Z(?:123|124)(?:xy|od).*?(:?;|$))/';
$str = 'Z124xy54;Z123od33;Z251od541;Z123od343;Z251ab541;Z123od343';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);