re = /(Z(?:123|124)(?:xy|od).*?(:?;|$))/
str = 'Z124xy54;Z123od33;Z251od541;Z123od343;Z251ab541;Z123od343'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end