// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(Z(?:123|124)(?:xy|od).*?(:?;|$))").unwrap();
let string = "Z124xy54;Z123od33;Z251od541;Z123od343;Z251ab541;Z123od343";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}