use strict;
my $str = 'Z124xy54;Z123od33;Z251od541;Z123od343;Z251ab541;Z123od343';
my $regex = qr/(Z(?:123|124)(?:xy|od).*?(:?;|$))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}