package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(Z(?:123|124)(?:xy|od).*?(:?;|$))`)
var str = `Z124xy54;Z123od33;Z251od541;Z123od343;Z251ab541;Z123od343`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}