const regex = /(Z(?:123|124)(?:xy|od).*?(:?;|$))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Z(?:123|124)(?:xy|od).*?(:?;|$))', 'g')
const str = `Z124xy54;Z123od33;Z251od541;Z123od343;Z251ab541;Z123od343`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}