using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)(?<=^info)(?:\r?\n){2}:(?:\r?\n){2}";
string substitution = @" : ";
string input = @"info
:
I went to Paris
xxx
yyy
zzz
info
:
I went to Italy
aaa
bbb
ccc
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}