import Foundation
let pattern = #"(?m)(?<=^info)(?:\r?\n){2}:(?:\r?\n){2}"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
info
:
I went to Paris
xxx
yyy
zzz
info
:
I went to Italy
aaa
bbb
ccc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" : "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)