use strict;
my $str = 'info
:
I went to Paris
xxx
yyy
zzz
info
:
I went to Italy
aaa
bbb
ccc
';
my $regex = qr/(?m)(?<=^info)(?:\r?\n){2}:(?:\r?\n){2}/mip;
my $subst = ' : ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";