import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(?<=^info)(?:\\r?\\n){2}:(?:\\r?\\n){2}";
final String string = "info\n\n"
+ ":\n\n"
+ "I went to Paris\n\n"
+ "xxx\n\n"
+ "yyy\n\n"
+ "zzz\n\n"
+ "info\n\n"
+ ":\n\n"
+ "I went to Italy\n\n"
+ "aaa\n\n"
+ "bbb\n\n"
+ "ccc\n";
final String subst = " : ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}