# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)(?<=^info)(?:\r?\n){2}:(?:\r?\n){2}"
test_str = ("info\n\n"
":\n\n"
"I went to Paris\n\n"
"xxx\n\n"
"yyy\n\n"
"zzz\n\n"
"info\n\n"
":\n\n"
"I went to Italy\n\n"
"aaa\n\n"
"bbb\n\n"
"ccc\n")
subst = " : "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.