using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*([0-9]{3}).*([0-9]{3}).*([0-9]{4})";
string input = @"970-800-6112
9708006112
(970) 800-6112
(970)800-6112
970.800.6112";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}