import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*([0-9]{3}).*([0-9]{3}).*([0-9]{4})";
final String string = "970-800-6112\n"
+ "9708006112\n"
+ "(970) 800-6112\n"
+ "(970)800-6112\n"
+ "970.800.6112";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}