// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*([0-9]{3}).*([0-9]{3}).*([0-9]{4})").unwrap();
let string = "970-800-6112
9708006112
(970) 800-6112
(970)800-6112
970.800.6112";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}