$re = '/.*([0-9]{3}).*([0-9]{3}).*([0-9]{4})/';
$str = '970-800-6112
9708006112
(970) 800-6112
(970)800-6112
970.800.6112';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);