package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*([0-9]{3}).*([0-9]{3}).*([0-9]{4})`)
var str = `970-800-6112
9708006112
(970) 800-6112
(970)800-6112
970.800.6112`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}