re = /.*([0-9]{3}).*([0-9]{3}).*([0-9]{4})/
str = '970-800-6112
9708006112
(970) 800-6112
(970)800-6112
970.800.6112'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end