#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:src|action|href)=[\'"]\K/(?!/)[^\'"]*"
Local $sString = "<img src="/relative/url/img.jpg" />" & @CRLF & _
"<form action="/">" & @CRLF & _
"<form action="/contact-us/">" & @CRLF & _
"<a href='/relative/url/'>Note the Single Quote</a>" & @CRLF & _
"<img src="//site.com/protocol-relative-img.jpg" />" & @CRLF & _
""
Local $sSubst = "https://example.com$0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)