$re = '~(?:src|action|href)=[\'"]\K/(?!/)[^\'"]*~';
$str = '<img src="/relative/url/img.jpg" />
<form action="/">
<form action="/contact-us/">
<a href=\'/relative/url/\'>Note the Single Quote</a>
<img src="//site.com/protocol-relative-img.jpg" />
';
$subst = "https://example.com$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;