import Foundation
let pattern = #"(?:src|action|href)=[\'"]\K/(?!/)[^\'"]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<img src="/relative/url/img.jpg" />
<form action="/">
<form action="/contact-us/">
<a href='/relative/url/'>Note the Single Quote</a>
<img src="//site.com/protocol-relative-img.jpg" />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"https://example.com$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)