using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:src|action|href)=[\'""]\K/(?!/)[^\'""]*";
string substitution = @"https://example.com$0";
string input = @"<img src=""/relative/url/img.jpg"" />
<form action=""/"">
<form action=""/contact-us/"">
<a href='/relative/url/'>Note the Single Quote</a>
<img src=""//site.com/protocol-relative-img.jpg"" />
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}