const regex = new RegExp('(?:src|action|href)=[\\\\'"]\\K/(?!/)[^\\\\'"]*', 'g')
const str = `<img src="/relative/url/img.jpg" />
<form action="/">
<form action="/contact-us/">
<a href='/relative/url/'>Note the Single Quote</a>
<img src="//site.com/protocol-relative-img.jpg" />
`;
const subst = `https://example.com$0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);