# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\!|\\|:|\?|@|%|#|'|\$|"|<|>|\^|\_|\[|\(|\)|\]|\[|\*|\\/|{|}|;|,|\+|&|\=|[\047])+/_/gm;t' <<< "t!]e'%7m*?p#%*file.txt"