$re = '/(\!|\\\\|:|\?|@|%|#|\'|\$|"|<|>|\^|\_|\[|\(|\)|\]|\[|\*|\/|{|}|;|,|\+|&|\=|[\047])+/m';
$str = 't!]e\'%7m*?p#%*file.txt';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;