using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\!|\\|:|\?|@|%|#|'|\$|""|<|>|\^|\_|\[|\(|\)|\]|\[|\*|\/|{|}|;|,|\+|&|\=|[\047])+";
string substitution = @"_";
string input = @"t!]e'%7m*?p#%*file.txt";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}