package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\!|\\|:|\?|@|%|#|'|\$|"|<|>|\^|\_|\[|\(|\)|\]|\[|\*|\/|{|}|;|,|\+|&|\=|[\047])+`)
var str = `t!]e'%7m*?p#%*file.txt`
var substitution = "_"
fmt.Println(re.ReplaceAllString(str, substitution))
}