re = /(\!|\\|:|\?|@|%|#|'|\$|"|<|>|\^|\_|\[|\(|\)|\]|\[|\*|\/|{|}|;|,|\+|&|\=|[\047])+/m
str = 't!]e\'%7m*?p#%*file.txt'
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result