use strict;
my $str = 't!]e\'%7m*?p#%*file.txt';
my $regex = qr/(\!|\\|:|\?|@|%|#|'|\$|"|<|>|\^|\_|\[|\(|\)|\]|\[|\*|\/|{|}|;|,|\+|&|\=|[\047])+/mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";