const regex = /(\!|\\|:|\?|@|%|#|'|\$|"|<|>|\^|\_|\[|\(|\)|\]|\[|\*|\/|{|}|;|,|\+|&|\=|[\047])+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\!|\\\\|:|\\?|@|%|#|\'|\\$|"|<|>|\\^|\\_|\\[|\\(|\\)|\\]|\\[|\\*|\\\/|{|}|;|,|\\+|&|\\=|[\\047])+', 'gm')
const str = `t!]e'%7m*?p#%*file.txt`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);