#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^.]*\.[^.]{2,3}(?:\.[^.]{2,3})?$"
Local $sString = "http://google.com" & @CRLF & _
"http://www.google.com" & @CRLF & _
"http://abc.cde.google.com" & @CRLF & _
"http://google.co.uk" & @CRLF & _
"http://www.google.com.au" & @CRLF & _
"http://www.mysite.info" & @CRLF & _
"http://www.mysite.business" & @CRLF & _
"http://www.gmx.de" & @CRLF & _
"http://localhost" & @CRLF & _
"" & @CRLF & _
"Optional:" & @CRLF & _
"http://google.com:8080" & @CRLF & _
"http://www.google.com?q=abc" & @CRLF & _
"http://www.google.com/smth" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")