# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^.]*\.[^.]{2,3}(?:\.[^.]{2,3})?$"
test_str = ("http://google.com\n"
"http://www.google.com\n"
"http://abc.cde.google.com\n"
"http://google.co.uk\n"
"http://www.google.com.au\n"
"http://www.mysite.info\n"
"http://www.mysite.business\n"
"http://www.gmx.de\n"
"http://localhost\n\n"
"Optional:\n"
"http://google.com:8080\n"
"http://www.google.com?q=abc\n"
"http://www.google.com/smth\n\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.