import Foundation
let pattern = #"[^.]*\.[^.]{2,3}(?:\.[^.]{2,3})?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://google.com
http://www.google.com
http://abc.cde.google.com
http://google.co.uk
http://www.google.com.au
http://www.mysite.info
http://www.mysite.business
http://www.gmx.de
http://localhost
Optional:
http://google.com:8080
http://www.google.com?q=abc
http://www.google.com/smth
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)