// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^.]*\.[^.]{2,3}(?:\.[^.]{2,3})?$").unwrap();
let string = "http://google.com
http://www.google.com
http://abc.cde.google.com
http://google.co.uk
http://www.google.com.au
http://www.mysite.info
http://www.mysite.business
http://www.gmx.de
http://localhost
Optional:
http://google.com:8080
http://www.google.com?q=abc
http://www.google.com/smth
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}