const regex = /[^.]*\.[^.]{2,3}(?:\.[^.]{2,3})?$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^.]*\\.[^.]{2,3}(?:\\.[^.]{2,3})?$', 'mg')
const str = `http://google.com
http://www.google.com
http://abc.cde.google.com
http://google.co.uk
http://www.google.com.au
http://www.mysite.info
http://www.mysite.business
http://www.gmx.de
http://localhost
Optional:
http://google.com:8080
http://www.google.com?q=abc
http://www.google.com/smth
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}